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ImageJ

 
http://rsbweb.nih.gov/ij/index.html 

 

Introdução ao ImageJ 

A janela de entrada do programa ImageJ consiste de 3 partes:  

 

1. Menu‐Bar (Barra de Menu),  

2. Toolbar (Barra de Ferramenta) e  

3. Status‐Bar (Barra de Informações).  
 

 

 

________________________________________________________________________________ 

Exercícios 2.1: Informação sobre Pixel, Zoom e Scrolling  
 

 Abra a imagem "A4 dapi 1.tif"  da pasta "01 – opening images".  
 

Note que algumas  informações  sobre a  imagem aberta  são apresentadas no  topo da  janela da 

própria imagem. Algumas informações são: tamanho da imagem em pixel (e/ou outra unidade de 

medida), o tipo e o tamanho da imagem para armazenamento na memória do computador. 
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Selecione a ferramenta de  lupa (magnifying glass tool) na barra de ferramentas e clique na área 

da imagem. Um clique com o botão esquerdo faz um zoom‐in, um com o botão direito do mouse 

um zoom‐out. Você pode usar as teclas [+] e [‐] para também fazer a operação de zoom. 

Observe a imagem com a área da imagem indicada no canto superior esquerdo, quando a imagem 

é maior que a janela de observação. 

Aplique  a  operação  de  Zoom‐in  para  que  o  indicador  de  posição  seja  exibido.  Selecione  a 

ferramenta de rolagem na barra de ferramentas. Clique na imagem e sem soltar o botão mova o 

mouse. Vá para o canto inferior direito da imagem. 

Selecione a ferramenta lupa (magnifying glass tool) novamente. Aplique a operação Zoom‐in para 

que o  indicador de posição seja exibido. Você pode arrastar a  imagem, mantendo pressionada a 

"barra de espaço" ao  invés de usar a ferramenta rolagem  (scroll). A vantagem é que você pode 

usar a barra de espaço para fazer uma rolagem da imagem quando uma outra ferramenta estiver 

ativa ao mesmo tempo.  

Amplie para o zoom máximo e mova o mouse sobre a  imagem. Olhe para a barra de status da 

janela de  inicio do  ImageJ. A posição do pixel sob o ponteiro do mouse e seu valor na escala de 

cinzas são exibidos. 

a) Qual é o zoom máximo possível? Qual é o zoom mínimo? 

Max = 3200% e mim =3,1% 

b) Qual é o valor em níveis de cinza do pixel com as coordenadas x = 549 e y = 305? Qual é o 

valor em níveis de cinza do pixel com as coordenadas x = 58 e y = 246? 

199 e 197 

c) Qual é a largura e altura da imagem? Qual é seu tipo? O que é o seu tamanho na memória? 

d) Mova o mouse sobre a imagem. Em qual sentido a coordenada X dos pixels se tornam maiores? 

Em qual sentido as coordenadas Y se tornam maiores ? Como é o sistema de coordenadas para 

uma imagem digital? 

A coordenada X varia da esquerda para a direita e o Y varia de cima para baixo 

e)  Você  pode  alterar  a  orientação  do  eixo‐Y.  Abra  o Menu  "Analyze>  Set Measurements..."  e 

selecione "Inverter as coordenadas Y". Passe o mouse sobre a imagem novamente.  

 

Exercício 2.2: ferramentas de seleção da área 

Certifique‐se que a  ferramenta de  seleção  retangular  (Rectangular Selection Tool) está ativa. A 

partir  dela  você  poderá  fazer  uma  seleção  retangular  na  imagem,  clicando  em  um  ponto  e 

arrastando o mouse para um outro ponto. Enquanto isso a largura, a altura e a relação de aspecto 

(aspect ratio) da seleção serão exibidos/modificados. Uma vez que você solte o botão do mouse 

você  terminou de  fazer uma seleção na  imagem digital. Você ainda poderá alterar sua posição, 

clicando nele e arrastando, ou clicando na borda e modificando seu tamanho. 
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a)  Faça  uma  seleção  retangular  na  imagem,  mova‐a  e  mude  seu  tamanho.  Descubra  na 

documentação  ImageJ  (ImageJ Guia  do Usuário)  quais  teclas modificadoras  existem  para  a 

ferramenta de seleção retangular e que elas fazem. Experimente‐as. 

b) Note que você pode criar seleções complexas usando a tecla [Shift] e [Alt]. [Shift] adiciona uma 

nova área seleção existente. [Alt] remove uma área de uma seleção já existente. Experimente 

ambos os métodos de seleção. Mova a seleção complexa ao redor de toda a imagem. Note‐se 

que você pode criar uma seleção, mesmo que as áreas individuais sejam separadas. 

Observação: A  tecla  [Alt] no  Linux não  funciona, para o mesmo  trabalho é preciso  segura o 

[Ctrl]  juntamente com o  [Alt], depois pode soltar o  [Ctrl] e continuar segura o  [Alt], e então 

teremos o mesmo efeito. 

c) Mude a cor de seleção para, por exemplo, magenta (Editar> Opções> Cores ...). 

d) Use o botão direito do mouse sobre a seleção retangular (rectangular‐selection tool‐button) e 

selecione  a  ferramenta  de  retângulo  arredondado  (rounded‐rectangle  selection).  Faça  uma 

seleção. Note‐se que todas as ferramentas de seleção usam a mesma cor definida exceto para 

a seleção  retângulo arredondado que  tem sua configuração própria cor. Você pode alterá‐la 

clicando duas vezes sobre a ferramenta de botão. 

e)  Dê  um  duplo  clique  sobre  a  ferramenta  de  retângulo  arredondado  (rounded‐rectangle 

selection). Altere o valor do tamanho do arco de canto para desenhar uma nova seleção. 

f) Tente as outras ferramentas de seleção de áreas da  imagem  incluindo a ferramenta freehand‐

selection  (seleção  livre). Note  que  ao  usar  a  ferramenta  freehand‐selection,  você  não  deve 

tentar fechá‐la você mesmo. Basta ir próximo do ponto de  início e soltar o botão do mouse. A 

seleção será fechada automaticamente. 

g) Faça uma seleção e execute o comando "Imagem> Recortar (Crop)". O que acontece? 

Você  pode  recarregar  a  imagem  original  usando  "File>Revert"  ou  (Ctrl  +  r].  Faça  uma 

seleção novamente  e  execute o  comando  "Imagem>Duplicar"  (Duplicate)  [Shift  + d]. O que 

acontece? 

 

Exercício 2.3: Medições e Tabela de Resultados 

O  comando  Analisar>  Medida  (Analyze>Measure),  tecla  [m],  realiza  medidas  tanto  de 

propriedades de  toda  a  imagem ou de uma  região previamente  selecionada na  imagem. Você 

poderá  escolher    as  propriedades  que  serão medidas  no Menu  "Anlyze>  Set Measurements". 

Todas  as  medidas  realizadas  serão  armazenadas  na  tabela  de  resultados  globais  (Janela  de 

Resultados). 

a) Use a ferramenta de freehand‐selection (seleção  livre)   para selecionar um núcleo (observado 

na  imagem),  em  seguida, meça  sua  área  e  valor médio  dos  níveis  de  cinza  no  interior  da 

seleção. Faça a mesma coisa para múltiplos núcleos. Aplique um zoom na  imagem para fazer 

uma seleção precisa. 
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b) Aplique a opção " File>Duplicate"1 para duplicar a tabela de resultados e fazer uma cópia dos 

mesmos. Meça  posteriormente  uma  nova  seleção.  A  qual  a  tabela  esses  novos  resultados 

foram acrescentados? 

c)  Use  "File>Rename"  (Arquivo>Renomear)  para  renomear  a  tabela  de  resultados  original 

(Resultados) para, por exemplo, "Resultados_Velho". Faça uma nova medida. Em que  tabela 

de resultados o mesmo é acrescentado? 

d) Limpe a  tabela de  resultados usando o Menu  " Results>Clear Results" e meça pelo menos 3 

novos núcleos. O que é a média, o desvio‐padrão, os parâmetros min, a max e o modo da 

distribuição da área de valores? Use "Use Results>Summarize" e "Results>Distribution"... para 

obter as respostas.  

1 ‐ Atenção: o menu "File" se encontra na janela de Resultados (Results) 

Exercício 2.4: ferramentas de seleção de linha 

Experimente as ferramentas de seleção de  linha em  linha reta (line selection tools straight‐line), 

linha‐segmentada (segmented‐line) e linha‐livre (freehand‐line). Note‐se que durante a criação da 

linha o  comprimento do  segmento  corrente e o ângulo  com o eixo  x  são exibidos na barra de 

informações (status‐bar). 

a) Utilize a ferramenta em linha reta (straight‐line tool) para estimar as distâncias entre os centros 

dos núcleos.  

b) Utilize a mesma ferramenta para estimar os diâmetros dos núcleos.  

c)  Use  a  ferramenta  de  linha‐segmentada  (segmented‐line)  para  estimar  os  perímetros  dos 

núcleos.  

d) Use a ferramenta linha‐livre (freehand‐line) para estimar os perímetros dos núcleos.  

e) Use a ferramenta ângulo para estimar os ângulos entre os três núcleos. 

 

Exercício 2.5: Gráfico de Perfil  

Você pode usar as  ferramentas de  seleção de  linha para criar gráficos de perfis. Um gráfico de 

perfil contém os valores de  intensidade dos pixels ao  longo da  linha  selecionada. Primeiro  faça 

uma seleção de  linha, por exemplo   através de um núcleo na  imagem, em seguida, pressione a 

tecla [k] (o atalho para "Analyze‐>Plot_Profile"). Note que, quando a largura de linha é maior do 

que um, o perfil será a média dos valores sobre esta largura. Você pode alterar a largura da linha 

de  seleção  por meio  de  um  duplo  clique  na  ferramenta  linha  de  seleção  (line‐selection  tool‐

button). 

a) Use a ferramenta "Plot Profile " por exemplo para estimar o diâmetro de um núcleo. Note que 

o plot (gráfico) é uma imagem também, de modo que você pode usar as mesmas ferramentas 

do ImageJ nela. Faça uma avaliação se existe alguma vantagem em se utilizar o mapa do perfil 

(Plot Profile) em vez de medir o diâmetro na imagem original? 
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b) Crie um " Plot Profile " através de um núcleo na imagem exemplo. Sem alterar a seleção, mude 

a linha de largura e crie um novo plot. O que mudou? 

d) Crie um " Plot Profile " através de um núcleo (da imagem exemplo). Clique no botão "List" na 

janela do gráfico de perfil. Copie os valores para o clipboard ([Ctrl + A] para selecionar todos e 

[CTRL  +  C]  para  copiar).  Abra  o  Ajuste  de  curvas  (Curve  Fitter)  em  "Analyze>Tools>  Curve 

Fitting...".  Exclua  os  valores  no  local  (se  houver  algum)  e  cole  os  valores  da  área  de 

transferência para ele [Ctrl + V]. Faça um ajuste Gaussiano dos pontos medidos. 

 

Exercício 2.6: seleções de pontos 

Você  pode  usar  as  ferramentas  de  seleção  pontuais  (point  selection  tools)  para  contar 

manualmente os objetos em uma imagem. Com o "Point Selection Tools" use a tecla [Shift] para 

adicionar pontos ou use a ferramenta multi‐ponto para adicionar mais de um ponto. Você pode 

apagar os pontos usando a tecla [Alt]. 

a) Faça uma seleção de ponto em três núcleos na  imagem teste, em seguida, faça um ponto em 

algum lugar no fundo da imagem e faça seleções de pontos em núcleos remanescentes. Exclua 

o ponto no fundo usando a tecla [Alt]. O que acontece com a numeração dos pontos? 

b) Salve uma  imagem com uma seleção de vários pontos em algum  lugar no disco utilizando   o 

formato  TIF  ("Save  as  >  TIFF"  ...).  Feche  a  imagem  e  recarregue‐a  ("File> Open  ..."). O  que 

aconteceu com a seleção de pontos? Você ainda pode modificá‐los? 

c) Marque a opção Auto‐Medida  (Auto‐Measure) da  ferramenta de pontos  (Point Tool). O que 

esta ferramenta faz? Dica: Veja a tabela de Resultados. 

d)  Você  pode  usar  a  ferramenta  seleção  de  ponto(s)  com  as  opções  "Auto‐Medida"  (Auto‐

Measure) e "Auto‐Next Slice" para  traçar a  trajetória de uma partícula. Por exemplo, abra a 

imagem  "particles.tif"  na  pasta  "02  ‐  basic  tools"  e  faça  o  teste,  com  o  ponto  amarelo  na 

sequencia de imagens.   

 

Exercício 2.7: Thresholding e a ferramenta de "varinha mágica" 

A ferramenta varinha mágica (magic wand tool) permite fazer uma seleção de pixels conectados 

em uma  imagem. Há duas maneiras diferentes para  se determinar quais pixels  farão parte da 

seleção  final:  (1) Ou a  ferramenta  seleciona  todos os pixels conectados com o valor de mesma 

intensidade  (eventualmente mais  ou menos  tolerância  a  partir  de  um  valor  inicial)  ou  (2)  ele 

seleciona  todos os pixels a partir de um  threshold  (limiar de  corte). Neste  caso ele  criará uma 

nova  imagem  com  todos os pixels  com  intensidades maiores do que o mínimo determinado e 

menores do que o  valor máximo  informado.  Será uma  imagem binária. O mínimo  (e máximo) 

valores‐limite podem ser definido usando o  limite de ajuste na  Janela de Threshold. Você pode 

abrir esta ferramenta de corte (threshold) a partir de "Image> Adjust> Threshold" [Shift + t]. No 

Menu de Threshold troque alternativamente (para ver o efeito) a opção de visualização de modo 

de vermelho (Red) para "Over/Under".  
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Cada clique com a ferramenta de seleção varinha mágica (magic wand tool) cria uma seleção. Se 

você quiser remover a seleção utilize a tecla [Ctrl + Shift + a]. 

a) Use a ferramenta de seleção varinha mágica (magic wand tool) em combinação com o ajuste de 

limiar  (threshold)  para  selecionar  núcleos.  Meça  os  núcleos.  Quais  são  os  maiores  e  os 

menores perímetros e quais são os diâmetros maiores e menores? 

b)  Use  a  ferramenta  de  seleção  varinha mágica  (magic  wand  tool)  para  selecionar  todos  os 

núcleos como uma seleção (shift‐clique). Descubra qual é a percentagem da área de imagem é 

coberta por núcleos. Dica: você pode usar CTRL + A para selecionar toda a imagem. 

 

Exercício 2.8: Gerenciador de Região de Interesse (Roi‐Manager) 

O Roi‐Manager é uma ferramenta que ajuda a trabalhar com seleções de pixels na imagem. Será 

nesta  seleção  (ou  seleções)  que  o  processamento  da  imagem  estará  concentrado.  Você  pode 

manter  um  número  ilimitado  de  seleções,  exibir,  modificar  e  medi‐los  quando  quiser.  Os 

comandos  do  gerente  de  regiões  ROI  (Region  of  Interest)  sempre  trabalhará  nas  ROIs 

selecionadas ou em todas as ROIs do gerenciador caso nenhuma delas esteja selecionada.  

a) Use  a  ferramenta  varinha  (wand‐tool)  para  selecionar  um  núcleo  na  imagem  exemplo,  em 

seguida, pressione a tecla [t] (atalho para adicionar a seleção ao Roi‐Manager, você encontrará 

a  janela  principal  do  ROI‐Manager  em  Analyze>Tools>ROI Manager  ...).  Selecione  a  opção 

Mostrar todas as seleções. 

b) Clique  em uma das  etiquetas  (por  exemplo na de número 5) na  imagem. Note que  a  linha 

correspondente  no  ROI‐Manager  é  selecionado.  Modifique  a  seleção  (remova  uma  peça 

usando freehand‐selection com a tecla [Alt] pressionada). Pressione o botão de atualização na 

ROI‐Manager para fazer a mudança permanentemente. 

c)  Selecione  uma  ou  várias  linhas  no  ROI‐Manager  (você  pode  usar  as  teclas  [Ctrl]  /  [Shift])  e 

pressione o botão medida (Measure). Pressione o botão Deselect, feche ou apague a tabela de 

resultados e pressione o botão medida (Measure) novamente para ver o resultado de ação da 

ferramenta. 

d) O que significa botão flatten (achatar)? Dica ‐ Dê uma olhada no tipo da imagem resultante. 

e) Defina o limiar inferior (lower threshold) de modo que o fundo se torne azul e não há furos nos 

núcleos. Você pode  criar uma  seleção a partir dos valores após o uso do  threshold  (valores 

após a limiarização/corte) usando Edit>Selection>Create Selection. Execute o comando Split do 

ROI‐Manager. O que acontece? 

f) Adicione as seleções de todos os núcleos para o ROI‐Manager. Agora abra a imagem "A4 Rhod 

1.tif" da pasta "02  ‐ basic tools". Com a  imagem recém carregada ativa, desmarque a opção 

Mostrar  Tudo  ("Show  All")  do  ROI‐Manager  e  selecione  a mesma  novamente.  Pressione  o 

botão medida. O que acontece? 
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Exercício 2.9: Medindo objetos com o Analisador de Partículas (Particle Analyzer) 

Até agora todas as seleções foram criadas individualmente. A ferramenta de Análise de Partículas 

permite  criar  automaticamente  uma  seleção  para  cada  objeto  (partícula),  região  ou  seja, 

conectado de pixels acima do limiar mínimo e abaixo do limite máximo de corte (threshold). 

a) Utilize o  limiar de corte  (Image> Adjust> Threshold ou  [shift +  t]) da  imagem, para adicionar 

núcleos para o Roi‐Manager  (desmarque  todas as opções  sobre a Particle‐Analyzer exceto a 

possibilidade "Adicionar ao Manager"). 

b) Apague todas as regiões do Roi‐Manager e use a ferramenta Particle‐Analyzer" de novo. Desta 

vez,  selecione  a  opção  Excluir  as  partículas  que  tocam  as  bordas  da  imagem.  Você  pode 

explicar para quais situações esta opção é boa e quando ela deve ser usada? 

c)  Use  o  analisador  de  partículas  de  novo,  porem  desta  vez,  o  objetivo  é  tentar  excluir 

objetos/regiões  que  são  demasiadamente  pequenas  para  serem  núcleos,  definindo  um 

tamanho mínimo na caixa de diálogo do Particle‐Analyzer. 

d)  Utilize  o  Analisador  de  Partícula  para  selecionar  apenas  os  núcleos  que  têm  um  valor  de 

circularidade elevada. Determine, com o uso da ferramenta, o valor que exclui os dois núcleos 

com a menor circularidade? O que você entende por circularidade? 

e) Abra  a  imagem  "inclusion.tif".  Imagine que o  interior e exterior dos  retângulos brancos  são 

partículas. Utilizar  a  ferramenta Particle‐Analyze, e  teste  a opção  com e  sem  a opção  furos 

(holes option). Interprete a diferença dos resultados nos dois casos? 

f) Use  o  Analisador  de  Partículas  para  descobrir  quantas  gotas  brilhantes  existem  na  imagem 

"blobs.gif" da pasta "02 ‐ ferramentas básicas". Qual é a área média das bolhas? 

 

Exercício 2.10: Setas, anotações e sobreposições 

Imagens podem  sofrer anotações de  forma não‐destrutiva, usando a  ferramenta  sobreposições 

(overlays). Opções como desenhos de setas e outras seleções podem ser adicionadas à  imagem 

sobreposta pressionando b (Image> Overlay> Selection). 

a) Utilize a (arrow tool) ferramenta Seta (acessível clicando com o botão direito do mouse sobre a 

opção de  linha  ‐  line‐selection  tool‐button) para criar setas que apontam para uma parte da 

imagem, no caso do exercício um núcleo. Antes de criar as setas, use as opções da ferramenta 

de seta (arrow‐tool) para definir a cor das setas, por exemplo para magenta. 

b) Use a ferramenta de texto (text tool) para escrever uma anotação para cada seta (por exemplo 

na direção do núcleo um e/ou do núcleo dois). Use [Ctrl+Alt+B] para adicionar o texto a uma 

camada de sobreposição (overlay). 

c) Modifique as setas. Dica: Use Image>Overlay>To ROI Manager primeiro. Não esqueça de clicar 

no  botão  Atualizar  (Update)  na  janela  de  gerenciamento  de  ROI  (Roi‐Manager),  depois  de 

modificar uma seta. 
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d) Substitua o texto por outro texto  (por exemplo aquele associado ao primeiro núcleo). Dica:  ‐ 

Você não pode modificar o texto em si. Selecione o texto no Roi‐Manager, escreva um novo 

texto com a ferramenta de texto e pressionar o botão de atualização. 

e) Adicione uma anotação de terceiro. Dica: Converta as seleções de volta em overlay, adicione 

nova anotação no overlay. 

f) Use "Image> Overlay> Flatten" para criar uma imagem que contém as anotações que você pode 

copiar para, por exemplo uma apresentação em slides. Nesta  imagem final (após o comando 

flatten) a anotação não será mais uma camada de sobreposição ou uma ROI. Os desenhos ou 

textos da camada de overlay serão transportados diretamente para a imagem final, alterando 

os valores dos pixels. 

 


